鲁西化工股票:【大智慧】拾金主图指标公式全球股指

股票配资 浏览

DRAWGBK(CLOSE>0,STRIP(RGB(0,128,128),RGB(25,25,112),0));
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );
STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),colorred;
SA:=(MM * 0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
财神爷:IF(((SSL > MM)),MM,SA),LINETHICK2,colorFF00FF;
VAR2Y:=(((CLOSE – REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3Y:=(((CLOSE – REF(OPEN,29)) / REF(OPEN,29)) * 100);
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE – VAR4Y),0),6,1) / SMA(ABS((CLOSE – VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE – VAR4Y),0),12,1) / SMA(ABS((CLOSE – VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE – VAR4Y),0),24,1) / SMA(ABS((CLOSE – VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE – LLV(LOW,45)) / (HHV(HIGH,45) – LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) – (2 * VARAY));
VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
VARDY:=((100 – CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));
DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.01),5),colorFFFFFF;
VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);
VARFY:= – ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VARFY,(0 – 9))),(LOW * 0.998),4);
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));
上开:=o;
上收:=c;
上高:=h;
上低:=l;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
B:REF(A,1),POINTDOT,COLORYELLOW;
智能黄金线:A,COLORYELLOW,LINETHICK1;
STICKLINE(((SSL < MM) ),财神爷,智能黄金线,0.1,0),COLORCYAN;
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(VA2,VA1),VA1*1.10,’止损’),ALIGN1,COLORyellow;
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 智能黄金线>REF(智能黄金线,1),VA1*0.98,’★买入’),COLOR00FF00;
选手A:=MA(上收,3);
箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);
t1:=MA(上收,20)>=REF(MA(上收,20),1);
t2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND t1;
t3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
选手:=MA(上收,2);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
t4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;
t5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;
Var1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
DRAWTEXT(Var3 >=Var4 and BARSTATUS=2,箱顶,’–中期好’),COLOR00FFFF;
DRAWTEXT( Var3B and BARSTATUS=2,箱底,’–短期好’),COLOR00FFFF;
DRAWTEXT(A95,0,20);
uoo:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 and g1)+1);
DRAWTEXT(CROSS(Var3,Var4)AND(C>=O)AND Var30,箱底,’★’),ALIGN0,COLORf00ff0;
DRAWTEXT(CROSS(Var4,Var3) AND Var4>75 ,箱顶*1.03,’★减磅’),COLORf0f000;
{K线}
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLORB0B0FF;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C99.9,H,L,0.5,0),COLOR3366FF;
{K线超卖提示}
SQ1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
SQ2:=SMA(MAX(C-REF(C,1),0),7,1)/SMA(ABS(C-REF(C,1)),7,1)*100;
CM1:=IF(SQ1 1.03));
{超卖一}STICKLINE(CM1 and IF(Kx and w and Zy1,-16,10)ref(买进价,1);
STICKLINE(买进条件 AND 财神爷>智能黄金线 AND 智能黄金线>REF(智能黄金线,1),L,L*0.998,7,0),COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
DRAWTEXT(cross(买线,卖线)AND 箱顶>=REF(箱顶,1),箱底,’★’),ALIGN0,color00ffff;
stickline(cross(买线,卖线),open,close,3,0),color00ffff;
stickline(cross(买线,卖线),h,l,0.5,0),color00ffff;

A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 – 10)) + IF(A6,10,(0 – 10))) + IF(A7,10,(0 – 10))) + IF(A8,10,(0 – 10))) + IF(A9,10,(0 – 10))) + IF(A11,10,(0 – 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));
阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);
止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));
止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);
TJTS1:=BARSTATUS=2 and c200;
k2:=hhv(h,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 or TJTS2 ,k2*0.99,’阻力位:’+NUMTOSTRN(阻力位1,2)+’ ‘),coloryellow,ALIGN2;
DRAWTEXT(TJTS1 or TJTS2 ,k2*0.99,’止损位:’+NUMTOSTRN(止损位1,2)+’ ‘),coloryellow ,ALIGN2;